Issues with site search
Incident Report for Mynewsdesk
Resolved
Site search is back to normal
Posted over 3 years ago. Jul 31, 2015 - 17:33 CEST
Investigating
Currently we are facing some issues with search. We are working with third party providers to solve this.
Posted over 3 years ago. Jul 31, 2015 - 15:08 CEST