Issues with Video
Incident Report for Mynewsdesk
Resolved
This incident has been resolved.
Posted over 3 years ago. Jul 15, 2015 - 14:59 CEST
Identified
We have a issue with uploading and viewing videos. We're working actively to resolve it. Thank you for your patience!
Posted over 3 years ago. Jul 15, 2015 - 13:20 CEST