Email delays
Incident Report for Mynewsdesk
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 25, 2016 - 22:35 CET
Monitoring
Our email provider Sendgrid are having issues with delays in email deliverability. For more information please follow Sendgrid's status page: http://status.sendgrid.com/incidents/1m5nq9537xsk
Posted almost 2 years ago. Nov 25, 2016 - 15:09 CET