Instagram API Limitations
Incident Report for Mynewsdesk
Resolved
Sorry for any inconvenience you have experienced due to the recent changes at Instagram API.

Newsrooms

On Friday afternoon last week we removed the option of creating Instagram feeds for username searches - this caused errors when trying to create new Instagram feeds. We are looking into enable oauth authentication that will make it possible to retrieve hits from your own account, but this is bigger project and we need to prioritize the work against other product priorities. If you have a feed that searched for a particular username, this feeds no longer are working - try to replace them with a tag-search instead.

Due to the new api-limits that Instagram have enforced, there might be delays until hits show up in your Instagram feed.

Monitor

Our provider that queries the Instagram API resolved an issue on Friday afternoon that caused Instagram hits not to be shown in the results. Results from Instagram have been coming in since Friday afternoon, but the results still are experiencing delays due to the new API limits that was enforced by Instagram. We have created a notice about this in the Monitor-tool.
Posted 7 months ago. Apr 10, 2018 - 13:53 CEST
Update
The recent changes in the Instagram API is affecting Mynewsdesk integration on how often we can query their API and how we are searching for public content. This have the following effects on our service:

Newsrooms

Search by username
Instagram feeds in Newsrooms that are searching media by username is no longer working. We have previously used an API for searching Public Global data that now has been closed down. Instagram are offering an API to retrieve hits from a users own account and we are investigating this possibility.

Search by tags
Instagram are still allowing to retrieve hits from tags and this queries are still working. We are however affected by Instagram’s new rate limit and there are delays before hits are shown in Instagram feeds on Newsrooms.


Monitor

Delays
Retrieving hits by searching for tags in Instagram still works, but we are also affected by Instagrams rate limiting resulting in delays on retrieving hits.
Posted 7 months ago. Apr 06, 2018 - 11:25 CEST
Identified
Instagram have, without a notice, changed on how often we can query their API:s. This affects on how Instagram Feeds are presented on Newsrooms and how we are retrieving hits in Monitor for Instagram posts.

We are looking into how we can throttle the requests to Instagram to mitigate the change.

Read more here https://techcrunch.com/2018/04/02/instagram-api-limit/
Posted 7 months ago. Apr 05, 2018 - 17:13 CEST