Degraded email deliverability
Incident Report for Mynewsdesk
Resolved
The issue with email deliverability is now resolved. We apologize for any inconveniences. Happy holidays!
Posted almost 3 years ago. Dec 22, 2015 - 15:57 CET
Monitoring
We have identified and fixed the issue.
Posted almost 3 years ago. Dec 22, 2015 - 10:13 CET
Investigating
We are investigating the issues, thank you for your patience.
Posted almost 3 years ago. Dec 22, 2015 - 09:42 CET