Issues with Audience Builder

Incident Report for Mynewsdesk

Resolved

This incident has been resolved.
Posted Nov 03, 2023 - 16:03 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2023 - 13:53 CET

Investigating

Some users are currently experiencing issues with Audience Builder. We are in contact with our service provider and hope to resolve the issue as soon as possible.
We apologize for the inconvenience.
Posted Nov 02, 2023 - 16:52 CET
This incident affected: Contacts.