Startpage not accessible
Incident Report for Mynewsdesk
Resolved
This incident has been resolved.
Posted 8 months ago. Mar 06, 2019 - 12:52 CET
Update
We are continuing to monitor for any further issues.
Posted 8 months ago. Mar 06, 2019 - 09:53 CET
Monitoring
The issue is solved. We still monitor the sites performance.
Posted 8 months ago. Mar 06, 2019 - 09:52 CET
Investigating
Our information and startpage aren't accessible right now.
Posted 8 months ago. Mar 06, 2019 - 08:50 CET
This incident affected: Startpage.